show/hide menu
Non classé

Excel : comprendre le SI

0

si00Vous utilisez pas, peu ou mal la fonction SI, voici donc quelques petites explications et astuces pour devenir un crack.

 

La fonction SI permet de renvoyer dans une cellule une valeur différente selon une ou plusieurs conditions. Elle correspond tout simplement à ?SI une condition ALORS j’affiche ceci SINON j’affiche cela?. Ce qui traduit en fonction Excel est notée ainsi :

  

SI(Test_logique;Valeur_si_vrai;Valeur_si_faux)

si03

Le 1er paramètre Test_logique doit toujours renvoyé VRAI ou FAUX, si ce paramètre vous renvois tout autre valeur, vous avez fait une erreur de saisie ou une erreur de raisonnement.
En fait, la plupart du temps ce paramètre contiendra un des opérateurs de comparaison :

  • Inférieur : <
  • Inférieur ou égale : <=
  • Supérieur : >
  • Supérieur ou égale : >=
  • Différent : <>
  • Egaux : =

Les 2 autres paramètres peuvent renvoyés un texte, mis entre guillemet, un nombre ou une formule (attention ! Ne pas rajouter le signe égal au début de la formule mise dans ces 2 paramètres).

si04Exemple 1 : Vous devez donnez une appréciation selon la note. Si celle-ci est supérieure à 10 alors on inscrit ?BIEN? sinon ?PASSABLE?

=SI(B2>10;"BIEN";"PASSABLE")

Exemple 2 : même tableau et on doit uniquement inscrire ?Reçu? si la note est supérieur ou égale à 10

=SI(B2>=10;"Reçu";"")

Mettre uniquement 2 guillemets permet de renvoyer un texte vide. La cellule n’affichera donc rien.

Exemple 3 : même tableau et si l’élève a 10 ou plus, alors inscrire "ATTEINT", sinon afficher le nombre de point qui lui manque

=SI(B2>=10;"ATTEINT";10-B2)

SI05

A votre tour d’essayer en testant ces formules dans le tableau ci-dessous

Petites astuces

Votre tableau contient une formule avec une division et tant que la valeur du diviseur n’ait pas indiquée votre formule renvois #DIV/0!
Utilisez un SI pour éviter cet affichage :
SI(cellule_diviseur<>0;votre_division;??) ou
SI(cellule_diviseur<>0;votre_division;0)

Votre tableau contient des formules renvoyant des erreurs, #N/A par exemple, utiliser un SI pour pallier à ce problème :
SI(ESTNA(votre_formule);??;votre_formule)
ou plus large
SI(ESTERREUR(votre_formule);??;votre_formule)

Ces dernières formules ne contiennent pas d’opérateurs de comparaisons dans le test, mais les fonctions commençant par EST renvois uniquement VRAI ou FAUX (le plus important pour le paramètre de test)

Cathy MONIER, MVP Excel

Auteur du site CathyAstuce

articles liés

Créer une table des matières avec Word 2011

Créer une table des matières avec Word 2011

Winston Struye, professeur chez Slideluck Youth Initiative nous parle de Sway

Winston Struye, professeur chez Slideluck Youth Initiative nous parle de Sway

Concepteur PowerPoint évolue !

Concepteur PowerPoint évolue !