show/hide menu
Non classé

Excel : les arrondis

1

arrondiQuelle galère les arrondis ! Je travailles sous Excel et je suis incapable de les gérer. Comment arrondir avec des décimales, sur un entier, à l’inférieur, le supérieur, au multiple ? Peux-tu m’expliquer comment faire ?
Bien sûr et avec grand plaisir, applique simplement les différentes fonctions que je t’indique ci-dessous. Dans toutes ces fonctions, j’arrondis un nombre situé dans la cellule A1

 

Arrondi à l’entier (pas de décimales)

=ARRONDI(A1;0)
Exemple : 124,3 renvoi 124 et 124,6 renvoi 125

Arrondi avec 2 décimales

=ARRONDI(A1;2)
Exemple : 124,123 renvoi 124,12

Si tu préfères un autre nombre de décimales, remplace le 2 par ton nombre de décimales

Arrondir au nombre inférieur

=ARRONDI.INF(A1;0)
Exemple : 124, 6 renvoi 124

le 2e paramètre indique le nombre de décimales, donc ici j’ai un entier.

Arrondir au nombre supérieur

=ARRONDI.SUP(A1;0)
Exemple : 124, 3 renvoi 125

Arrondir au multiple

Cette fois-ci nous n’arrondissons pas à l’entier ou aux décimales indiquées mais tous les tant. Exemple : de 5 en 5, ou de 100 en 100, ou de 0,5 en 0,5
Il existe plusieurs fonctions pour atteindre cet arrondi au multiple et selon les paramètres tu devras choisir celle qui te convient. Dans les exemples, le nombre à arrondir se trouve en A1 et le multiple en A2

Pour arrondir au multiple en s’éloignant de 0
  • =ARRONDI.AU.MULTIPLE(A1;A2)
  • =PLAFOND(A1;A2)
  • =PLAFOND.PRECIS(A1;A2)

Selon le signe du nombre et du multiple, la valeur renvoyée peut-être différente :

A

B

C

124,3 124,5 ARRONDI.AU.MULTIPLE(A1;A2)
0,5 124,5 PLAFOND(A1;A2)
  124,5 PLAFOND.PRECIS(A1;A2)
-124,3 #NOMBRE! ARRONDI.AU.MULTIPLE(A1;A2)
0,5 -124 PLAFOND(A1;A2)
  -124 PLAFOND.PRECIS(A1;A2)
-124,3 -124,5 ARRONDI.AU.MULTIPLE(A1;A2)
-0,5 -124,5 PLAFOND(A1;A2)
  -124 PLAFOND.PRECIS(A1;A2)
124,3 #NOMBRE! ARRONDI.AU.MULTIPLE(A1;A2)
-0,5 #NOMBRE! PLAFOND(A1;A2)
  124,5 PLAFOND.PRECIS(A1;A2)

A l’étude de ces différentes fonction, on constate que PLAFOND.PRECIS permet le récupérer un arrondi au multiple le plus cohérent et sans afficher d’erreur

Pour arrondir au multiple en se rapprochant de 0
  • =PLANCHER(A1;A2)
  • =PLANCHER.PRECIS(A1;A2)

Selon le signe du nombre et du multiple, la valeur renvoyée peut-être différente :

A

B

C

124,3 124 PLANCHER(A1;A2)
0,5 124 PLANCHER.PRECIS(A1;A2)
-124,3 -124,5 PLANCHER(A1;A2)
0,5 -124,5 PLANCHER.PRECIS(A1;A2)
124,3 #NOMBRE! PLANCHER(A1;A2)
-0,5 124 PLANCHER.PRECIS(A1;A2)
-124,3 -124 PLANCHER(A1;A2)
-0,5 -124,5 PLANCHER.PRECIS(A1;A2)

On constate que PLANCHER.PRECIS permet le récupérer un arrondi au multiple le plus cohérent et sans afficher d’erreur.

A toi d’utiliser toutes ces fonctions?

Cathy MONIER, MVP Excel
Auteur du site CathyAstuce

articles liés

Créer une table des matières avec Word 2011

Créer une table des matières avec Word 2011

Winston Struye, professeur chez Slideluck Youth Initiative nous parle de Sway

Winston Struye, professeur chez Slideluck Youth Initiative nous parle de Sway

Concepteur PowerPoint évolue !

Concepteur PowerPoint évolue !

  • TOUPIN

    Je fais une formule excel et je souhaiterais qu’automatiquement l’arrondi supérieur soit fait. Et non être obligé de créer une colonne supplémentaire. Merci